wdjh.net
当前位置:首页 >> mAvEn2 missing jAr包问题 >>

mAvEn2 missing jAr包问题

检查一下你在pom.xml中对这三个包的设置。 然后检查一下如果没有包时,默认的下载地址。 有可能是你本地库没有这三个包,设置的下载地址又下不到造成的。 解决方法就是检查上面的设置。如果都没问题,是可以从远程库下载的。 如果还不行,建议去...

检查一下你在pom.xml中对这三个包的设置。 然后检查一下如果没有包时,默认的下载地址。 有可能是你本地库没有这三个包,设置的下载地址又下不到造成的。 解决方法就是检查上面的设置。如果都没问题,是可以从远程库下载的。 如果还不行,建议去...

右键工程---- 通过这个下载安装缺失的jar包。 右键工程--<Maven>--<Project更新> 然后就好了。我的Eclipse是日文版的,英文版的”实行”应该叫”Run”吧

maven缺少jar包,需要将包下载下来,执行maven install命令,将依赖的工程安装到本地仓库即可, 即执行: mvn clean install 命令。

缺失了javax.jms:jms:jar:1.1 这个包 看看是不是中央maven库中也没有这个包。 这个是sun的包,涉版权问题,可能中央库已经把这个包移除了。 如果是这种情况,需要引入本地的这个包进去

网上有的说什么删除一次jar包,还有楼上说的这些方案。只能是其中之一。一般情况下,只要从远程私服上下载下来的就不会出错,你想都能下载下来了,你的配置还能有错?最主要的有些jar包是要指定特定的jdk版本才行,比如说net.sf.json-lib这个包...

右键工程---- 通过这个下载安装缺失的jar包。 右键工程--<Maven>--<Project更新> 然后就好了。Eclipse是日文版的,英文版的”实行”应该叫”Run”

json-lib是需要区分jdk版本的,pom.xml中的配置应加上标签,如用jdk15: net.sf.json-lib json-lib 2.2.3 jdk15 总之,以上标签是必须的,如果还是Missing,可能是因为网络原因导致下载失败。请查看本地仓库net\sf\json-lib\json-lib\2.2.3目录...

那就是你的私服没有提供这个jar的下载了

把仓库里的JAR删掉 重新下载就OK了

网站首页 | 网站地图
All rights reserved Powered by www.wdjh.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com